Hello Members,

Just a note about updates occurring for devices and browsers you may utilize to access your accounts.

Necessary Upgrades for Access to Online Banking & Mobile App – Transport Layer Security (TLS)

On November 14, 2018, our online banking provider discontinued support for devices and browsers not using Transport Layer Security (TLS) 1.2. We strive to offer the most secure environments for online and mobile banking applications, therefore older versions of TLS have been deemed no longer adequate from a security perspective. This may affect your mobile and browser access to our online and mobile banking logins which may require updating to support TLS 1.2.  Determine if you need to update your browser settings or device systems in this link .

We are very sorry for any inconvenience this may cause you.

If, after consulting our FAQ list in the link above, you are still having issues determining your browser level, please feel free to give us a call at 800.279.3288 or 303.239.1150 or 303.234.1700.