As of 01/31/18, we have switched over to TLS 1.2 as older versions have been deemed no longer adequate from a security perspective. You will find device specific information below which will help you determine if you need to update browser settings/operating systems to be compatible with TSL 1.2.

 

Android

Android OS versions 4.5 and newer support TLS 1.2. Android devices running on OS 4.4 or older do not support TLS 1.2. If you are running on an unsupported OS, you will need to update your OS to a supported version.

Apple

Apple devices all support TLS 1.2. However, online banking on any iOS devices running on OS versions less than 9 will not be supported as of 01/31/18. iOS users on older devices with non-supported OS might find they still can log in for a period of time, but they will be on ‘non-supported’ versions.

Browsers

The majority of newer browser versions are compatible with TLS 1.2. If your online banking is not working with your current browser, visit here to be provided with instructions on updating your browser settings.

Comment on this FAQ

Your email address will not be published. Required fields are marked *